SMILE Hi10 Neuling braucht etwas Starthilfe für AUX-Ausgang und ModBus

Willkommen auf Storion4you.de - der Community für Stromspeicher- und Backupsysteme von ALPHA-ESS!
Sie haben aktuell Lesezugriff auf den öffentlichen Bereich dieser Website. Um Themen zu starten oder Beiträge zu erstellen, müssen Sie sich zuerst registrieren.

  • Hallo,

    ich habe seit etwa 14 Tagen eine SMILE Hi10 mit Batterie und 2 Stränge mit je 15 Panels.

    Ich habe jetzt schon vieles im Netz gelesen, aber irgendwie fehlt mir der richtig Anpack.

    Ich habe 2 Wünsche.

    1. Über den AUX-Ausgang möchte ich bei überschüssigem PV-Strom das Warmwasser aufheizen. Meine Hi10 hat den 6 poligen Stecker am AUX.

    Wo bekomme ich den passenden Stecker?

    Hat jemand im Netz schon eine Bauanleitung bzw. Tipps, Tricks, Hilfestellungen?

    2. Ich möchte gerne sehen, was meine beiden PV-Stränge einzeln an Leistung bringen. Wenn ich es richtig verstehe, kann man die Daten nur über den ModBus auslesen.

    Über die normale WLAN Schnittstelle kommt man da nicht dran?

    Bei dem ModBus gibt es wohl 2 Varianten, RS485 und TCP. TCP scheint wohl nicht zu funktionieren, oder?

    Kann man für die RS485 einen handelsüblichen RS485<--->LAN/WLAN Wandler nehmen? Worauf sollte man beim Kauf achten?

    Gibt es da schon Software Routinen im Netz?

    Das Projekt "solaranzeige.de" ist für meine Anwendung zwar etwas überdimensioniert, aber ich konnte keine Angabe finden, dass die SMILE Hi10 unterstützt wird. Hat da jemand Erfahrungen?

    Wenn Ihr sonst noch Tipps/Links in diese Richtung habt, gerne her damit.

    Danke im Voraus

    Martin

  • Hallo Martin,


    wir wohnen vielleicht gerade mal 40 km auseinander!


    zu 1.) Habe ich keine Erfahrungen mit. Ich benutze für diese Funktionen Home Assistant, da kann ich mit den Werten aus 2.) Automationen bauen, die mehr Regeln beinhalten als in den AUX-Einstellungen.


    zu 2.) Ich lese die Werte alle über Home Assistant im Zusammenspiel mit der Modbus-Erweiterung von unserem User Snitzelweck92 aus.

    GitHub - snitzelweck92/homeassistant_alphaess_modbus_tcp: This repository provides some .yaml files for home assistant.
    This repository provides some .yaml files for home assistant. - GitHub - snitzelweck92/homeassistant_alphaess_modbus_tcp: This repository provides some .yaml…
    github.com


    Das funktioniert ganz gut bei mir und dort kann ich PV1 und PV2 auslesen (kWh , Spannung und Strom)


    Das ganze funktioniert bei meinem Hi10 über den LAN-Port per ModbusTCP. Dafür brauchst Du keinerlei Adapter oder Umwandler. Du musst halt nur den Hi10 in dem LAN Deines HomeAssistant connecten.


    VG

    Ralph

    Alpha-ESS SMILE-H10 mit 10,6 kWh Solarmodule (14x410W Süd, 12*410W Nord), 7,8 kWh Batteriespeicher, keine Backup Box, Zappi 2.1 Wallbox, Opel Mokka mit 50 kWh Akku als Einspeisealternative ;)

  • Das ganze funktioniert bei meinem Hi10 über den LAN-Port per ModbusTCP. Dafür brauchst Du keinerlei Adapter oder Umwandler. Du musst halt nur den Hi10 in dem LAN Deines HomeAssistant connecten.


    VG

    Ralph

    Hallo Ralph,


    das hört sich gut an. Nur habe ich dort wo die Alpha steht keinen Zugang zu meinem Router, oder dem HA Raspi. Kann man den Lan-Ausgang auch mit einem Adapter ins Wlan bringen und dann so die Verbindung zu HA herstellen ? (Adapter andersrum gibt es ja: Adapter von Wlan-> Lan. Habe ich bei meinem Fernseher benutzt)


    Gruß

    Speedy

    Alpha-ESS SMILE-Hi10-INV mit 7,8 kWh Batteriespeicher und Backup Box / 11,48 kWp / SW = 14 x Solyco Solar 410 W / NO = 14 x Solyco Solar 410 W

  • Ja so einen "Adapter " habe ich mir mal mit einem Rasperry 4 und einem Image aus OpenWrt gebaut. Das ist garnicht mal so kompliziert.

    Der Raspi ist dan ein LAN auf WLAN Aadpter.


    Ich bin mir aber nicht sicher, ob dann die ModbusTCP Pakete durchgehen.


    Alternativ könnte man auch einen Devolo LAN Adapter nehmen, der das LAN über das Stromnetz überträgt, aber das hat bei mir nicht funktioniert (Die Devolo Geräte haben sich nicht gefunden). Der Solateur hat das dann wieder mitgenommen und ich habe ein LAN-Kabel in den Keller gezogen.


    Ein Repeater von von Fritz müsste eigentlich auch gehen.

    Alpha-ESS SMILE-H10 mit 10,6 kWh Solarmodule (14x410W Süd, 12*410W Nord), 7,8 kWh Batteriespeicher, keine Backup Box, Zappi 2.1 Wallbox, Opel Mokka mit 50 kWh Akku als Einspeisealternative ;)

  • Hallo Ralph,

    danke für die Info.

    Die SMILE-Hi10 per LAN Kabel mit einer FritzBox zu verbinden, ist ja noch das einfachste.

    Dann muss man noch ein "Home Assistant" System aufsetzen, so habe ich das verstanden, nachdem ich es mal kurz überflogen habe.

    Gibt es dan nicht etwas einfacheres? Irgendwie ein paar C-Zeilen kompelieren und dann einfach eine EXE starten?


    Noch eine dumme Frage: ich habe einen "SMILE-Hi10", in der APP steht "SMILE -T10-HV-INV", das ist doch eigentlich ein anderes System? Ist die APP für beide oder wie verstehe ich das? Sind die kompatibel? Auch der ModBus kompatibel?

    Danke

    VG Martin


    .

  • Das werde ich mal im Hinterkopf behalten und wenn die Anlage dann endlich läuft später mal ausprobieren, wahrscheinlich mit den Powerline Adaptern.

    Danke für den Tipp


    Gruss

    Speedy

    Alpha-ESS SMILE-Hi10-INV mit 7,8 kWh Batteriespeicher und Backup Box / 11,48 kWp / SW = 14 x Solyco Solar 410 W / NO = 14 x Solyco Solar 410 W

  • Ach da fällt mir noch eine andere Lösung ein. Die finde ich aber nicht so komfortabel. Es geht mit dem Chrome Browser und der Alpha Web Cloud. Das habe ich aus einer FB Gruppe.


    Alpha-ESS SMILE-H10 mit 10,6 kWh Solarmodule (14x410W Süd, 12*410W Nord), 7,8 kWh Batteriespeicher, keine Backup Box, Zappi 2.1 Wallbox, Opel Mokka mit 50 kWh Akku als Einspeisealternative ;)

  • Ja so einen "Adapter " habe ich mir mal mit einem Rasperry 4 und einem Image aus OpenWrt gebaut. Das ist garnicht mal so kompliziert.

    Wenn man nicht basteln will, kann man für so was ("WLAN Bridge") auch fertige Lösungen wie z.B. den Fritz Repeater 1200 AX nehmen.

    Ich möchte gerne sehen, was meine beiden PV-Stränge einzeln an Leistung bringen. Wenn ich es richtig verstehe, kann man die Daten nur über den ModBus auslesen.

    Da gibt es viele Möglichkeiten, Wace hat ja schon eine davon genannt (hass). Eine weitere wäre ioBroker mit dem Alpha-ESS Adapter: ioBroker Adapter für Alpha ESS zur Abfrage von Echtzeitwerten, Settings und Energiewerten

    Der Vorteil dabei: Das kannst du innerhalb weniger Minuten zum Ausprobieren auf einem vorhandenen Windows PC installieren und einrichten.

    --

    Bitte keine technischen Fragen per privater Konversation.

    Stellt eure Fragen im Forum, dann haben alle was davon und es können auch mehr Leute helfen.

  • 2. Ich möchte gerne sehen, was meine beiden PV-Stränge einzeln an Leistung bringen. Wenn ich es richtig verstehe, kann man die Daten nur über den ModBus auslesen.

    Über die normale WLAN Schnittstelle kommt man da nicht dran?

    Das war auch eine meiner ersten Anforderungen nach der Installation der Anlage im Januar. Man hat mich hier sehr freundlich mit viel Unterstützung auf den ioBroker verwiesen 😉. Erst auf dem PC, jetzt auf dem Raspberry. Allerdings hatte ich bei der Installation auf eine LAN Anbindung bestanden. Und damit läuft ModBus und Co ohne Probleme.


    Und die Verwirrung mit der Gerätebezeichnung hatte ich auch. Wenn Du auf den Aufkleber schaust, steht da sogar nur T10, aber mit HV INV. Somit ist es eine HI10 (Datenblatt). Der Vorgänger hatte die Bezeichnung T10 ohne Zusatz … glaube ich zumindest 😉

    _______________________________________

    SMILE-HI 10 7,8 kWh Akku

    9,5 kWp - 27 x QCELLS 355Wp - 17 Dach S/W 10 Dach N/O

    DTSU 666 - 3-phasig

    _______________________________________

  • Ich werde es erstmal mit der Anbindung an Home Assistant über Wlan testen. Das ist am einfachsten. Nachträglich ändern, bzw. Ausbauen kann man ja immer noch :)


    Gruß

    Speedy

    Alpha-ESS SMILE-Hi10-INV mit 7,8 kWh Batteriespeicher und Backup Box / 11,48 kWp / SW = 14 x Solyco Solar 410 W / NO = 14 x Solyco Solar 410 W

  • Hallo Martin,

    ich habe seit 2 Monaten den gleichen HI10 Wechselrichter mit der neuesten Ausstattung in Betrieb und nutze für Informationen die Solaranzeige. Hier habe ich die Verbindung über Modbus RTU an einen Raspi erstellt. Bei der Solaranzeige habe ich das Alpha Gerät ausgewählt, es gibt nur eins bei der Installation, Da dann aber beim hochfahren des Raspi ein Versionsfehler auftauchte, habe ich die Alpha-ESS php von Solaranzeige etwas modifiziert, jetzt läuft es, Dort kann man die einzelnen Stränge einfach abfragen.

    Der 6 polige AUX Stecker wird bei der Installation mitgeliefert. Schau mal nach ob er nicht da ist.

    Liebe Grüße Jürgen

  • Hallo Martin,

    ich habe seit 2 Monaten den gleichen HI10 Wechselrichter mit der neuesten Ausstattung in Betrieb und nutze für Informationen die Solaranzeige. Hier habe ich die Verbindung über Modbus RTU an einen Raspi erstellt. Bei der Solaranzeige habe ich das Alpha Gerät ausgewählt, es gibt nur eins bei der Installation, Da dann aber beim hochfahren des Raspi ein Versionsfehler auftauchte, habe ich die Alpha-ESS php von Solaranzeige etwas modifiziert, jetzt läuft es, Dort kann man die einzelnen Stränge einfach abfragen.

    Der 6 polige AUX Stecker wird bei der Installation mitgeliefert. Schau mal nach ob er nicht da ist.

    Liebe Grüße Jürgen

    Dann müsste der Aux Stecker draufgesteckt sein bei der Auslieferung. Richtig? Es wurde aber bei mir nach der Installation wieder der Deckel durch die die Kabel für Kommunikation und Grid geführt sind wieder aufgeschraubt. Somit sieht man den Stecker nicht. Anfang des Jahres wird dort eine WP angeschlossen. Hoffe der Stecker steckt 😉. Aber ich glaube, dass das ein Standardstecker ist.

    _______________________________________

    SMILE-HI 10 7,8 kWh Akku

    9,5 kWp - 27 x QCELLS 355Wp - 17 Dach S/W 10 Dach N/O

    DTSU 666 - 3-phasig

    _______________________________________

  • Der Stecker ist leider nicht vorhanden, steckt auch nicht. Da muss ich beim Installateur nachfragen.


    Also doch einen Hi10, danke


    JuergenW

    Auf Solaranzeige habe ich auch schon geschaut, finde ich auch sehr interessant.

    Die Verbindung hast Du also über RS485 gemacht. Hat das auch schon jemand über das Netzwerk geschafft?

    Kannst Du mir sagen, welche Anpassung Du gemacht hast?

    Hast Du schon andere Funktionen realisiert, z.B. Steuerungsaufgaben in Abhängigkeit von bestimmten Werte o.ä.?


    Wace

    Es klappt tatsächlich, danke, ist aber wirklich alles andere als komfortabel.

    Wer einen deutschen Firefox hat:

    - F12

    - Netzwerkanalyse

    - GetLastPowerDataBySN.... (alle 5 Sek neue Zeile)

    - rechte Titelzeile "Antwort"

    - eventuell Datenfeld mit dem kleinen Dreieck vor "data: Obect{...} aufklappen

    - dann erscheint in der Liste ppv1, ppv2 ....

  • Hallo Martin,

    Ja ich habe die Verbindung über Modbus RTU (RS485) gemacht. Modbus TCP wird aktuell (LAN Netzwerk) wird aktuell nicht unterstützt. Es wird immer mal wieder angefragt, aber bis jetzt hat das noch keiner programmiert. In der Alpha-Ess. PHP habe ich eine zusätzliche IF Abfrage auf die SW Version eingebaut. Ist einfach, kann ich zur Verfügung stellen. Ich habe bisher noch keine weiteren Funktionen realisiert, da ich noch auf WP und Wallbox warte. Aber im Forum stehen sehr viele Beispiele